iPalette
Requires Mac OS X 10.5+

Screenshots